Required Software Update - StarFire™ 3000, StarFire™ 6000, and StarFire™ 6000 integrated receivers.

posted on Tuesday, September 1, 2020 in Precision Ag

As John Deere continues to develop new technology, StarFire™ Network changes are necessary to support new satellite constellations and additional improvements. This update requires the introduction of a new signal. StarFire™ 6000 and StarFire™ 3000 receivers must be updated to the 20-2 software update to continue operating on the new signal.
 

To avoid any interruption in AutoTrac™ functionality, Update all receivers before February 1st, 2021. StarFire™ iTC receivers will not function on the new signal beginning February 1st, 2021, but will continue to operate in WAAS, EGNOS, or Non-Diff (depending on location) until approximately 2026. *AutoTrac™ will not function on WAAS or EGNOS

Software versions

StarFire™ 3000 – 2.80S - Requires software version 1.30D or later before updating to 2.80S.

StarFire™ 6000 – 4.40N - Requires software version 3.70M or later before updating to 4.40N.


How can you update your receiver?

  • Check for updates on GS Live Update on your PC to obtain 20-2 software.
  • Download software from Stellar Support yourself and update it via USB drive.
  • Use Over-The-Air software updates (receiver needs to be connected to the machine with an active JD Link subscription).
  • Bring your receiver to the service department at your nearest KFG location.
  • Schedule a KFG service tech to come to your farm and help with the update.


Helpful videos and guides for updating your receiver.

How to update your StarFire™ 3000 receiver

How to update your StarFire™ 6000 receiver

GS3 2630 Over-The-Air update

How to update StarFire™ receiver via GS2 2600


Have questions or need help with updates?

Contact Us